Home > IT, linux, windows > Maven Error: generics are not supported in source 1.3

Maven Error: generics are not supported in source 1.3

2009/06/22

Just stumbled across this error while trying to compile a simple Java Maven project:

Maven Error: generics are not supported in source 1.3

It turns out that maven uses the Java compiler 1.3 (!) by default. So you have to add the configuration settings to your pom.xml file…

See Hobione’s Blog entry on the same issue.

Advertisements
  1. 2009/07/07 at 05:00

    Great post!

  2. 2009/12/12 at 04:00

    Great issue, I did not thought reading it was going to be so stunning when I looked at the title!!

  1. No trackbacks yet.
Comments are closed.
%d bloggers like this: